Skip to Main Content
HCL Domino Ideas Portal

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.


For more information on products and upcoming events around #dominoforever, please visit: HCL Domino Page


ADD A NEW IDEA

Clear

Domino

Notes Named Documents should have accompanying @Formula commands

Domino 12.0.1 introduced the Notes Named documents. See https://help.hcltechsw.com/dom_designer/12.0.0/basic/wn_nameddocumentmethods.html However, this function has no @Formula counterpart, making it harder to integrate in the UI. Next to @GetProf...
almost 3 years ago in Domino / General 1 Under Consideration

Valid Semantic HTML5

The context of these suggestions is Notes Rich-Text in document, forms and pages. XPages are not considered in this text. We need to be able to produce valid HTML5 with Domino Forms, Views, Pages and so on. Please make valid HTML5 a success criter...
about 5 years ago in Domino / Integration 5 Under Consideration

Support UTF-8 for all IND files

Currently IND files are expected to be in native character sets.This charset differs between platform and is complicated to handle. The more standard and easier to handle charset today would be UTF-8. Cross platform format Easier creation of files...
almost 2 years ago in Domino / General 0 Needs Review

Retrieve Database Replication History Summary Using LotusScript.

This idea focuses on using LotusScript to programmatically extract and present a concise summary of database replication history in HCL Domino / IBM Notes, enabling administrators to easily monitor replication status and identify potential issues. ⚙️
8 months ago in Domino / Administration 0 Needs Review

Ability to login DRAPI using Java/LS bindings in Domino

DRAPI is expanding capabilities beyond what we can do using standard Domino programming. For instance, we can launch a co-editing, OData integration through the Domino Rest API or running background agents asynchronously. We could use these capabi...
over 1 year ago in Domino / Security 1 Needs Review

Server-Rules for E-Mail-Header

Our provider uses anti-spam software that writes the SPAM probability in the email header. Example: X-Spam-Level: ***** There should be a central way to evaluate the email header in Domino, for example to add a keyword to the subject line of affec...
over 2 years ago in Domino / Security 2 Under Consideration

Support emojis in Subject line in iNotes and Notes Client

Currently emojis are not supported in subject line when sending mails from iNotes and Notes Client. Even if we add the emojis then they may be rendered differently at the time of receiving mail by recipient. So there is a feature request to fully ...
over 1 year ago in Domino / Administration 0 Needs Review

Expose the Admin Console through the C-api

Currently there is no way to read from the Admin console using the C-api (or any language for that matter) except for reading the Log.nsf database. The problem is that those log lines must already be commited to disk which prevents us from creatin...
about 1 month ago in Domino / Integration 0 Needs Review

Support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533)

Domino should support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533) RFC 6532 and RFC 6531 allow the inclusion of Unicode characters in a header content using UTF-8 encoding, and their transmissio...
over 5 years ago in Domino 0 Assessment

Allow 2FA to use Email Only

We host systems that are used by customers who change companies all the time. Sometimes when they leave companies, we are not notified. Since people now take their BYOD phones with them, any MFA/2FA using SMS or Authenticator Apps can be used outs...
over 1 year ago in Domino / Security 5 No Plans to Implement