Skip to Main Content
HCL Domino Ideas Portal

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.


For more information on products and upcoming events around #dominoforever, please visit: HCL Domino Page


ADD A NEW IDEA

Clear

Pinned ideas

PINNED Use React components to render Notes applications
As a user I need Notes to open an application and show it using modern React based components, because it will look more modern, will be reactive to screen size, be better for accessibility, give us useful additional controls and allow us to contr...

Ideas

Excluding forms directly from full-text indexes is not supported.

In Domino 12, there is an option to exclude fields from full-text indexes. Please refer to the article below for the steps and more details. Title: Specifying fields to exclude from full-text indexes https://help.hcl-software.com/dom_designer/12.0...
almost 2 years ago in Domino / General 1 Needs Review

Can't expand the group members after click + from To field

Reproduce steps: 1. Create internet group in Domino directory with mail domain & group internet address. 2. Open outlook, create a new memo, select the created group from domino directory. 3. The group name is added in To field, the group name...
almost 5 years ago in Traveler for Microsoft Outlook-HTMO 1 Assessment

Delegate a calendar entry to another attendee to control the meeting for vacations, schedule conflicts, etc.

In many cases, repeating meetings are still held even when the meeting owner is out of the office on vacation, or needs to attend a different call. It would make calendar management easier if the owner could designate someone else as the owner of ...
over 5 years ago in Notes 0 Future Consideration

New option to Save mail message as eml file in the context menu

Many users who are not familiar with Notes Client ask how to save messages as eml files and new users who are not familiar with Notes usability are not in the habit of looking in File> Preferences> Basic Notes client setup to find the option...
over 5 years ago in Notes 1 Future Consideration

Changes in repeating calendar entries have to be sent in one email to O365 and other external users

The current behaviour: User creates an appointment/meeting that is repeatingThe repeating is one day a week, for five weeks, for example every Monday at 9 o'clockThe user invites one external user, who uses Exchange/Outlook/O365The external user g...
almost 2 years ago in Notes 1 Needs Review

Use IF1 or 2... instead of SHF123 as product version. SHF is IBM internal management number, is not understadable what it is all about.

SHF is used for everywhere in Interim Fix (IF) like in product (Help - About) and downloaded program like 852FP4SHF470_W32_standard.exe. IF number shall be added. SHF is IBM internal management number and nothing to do with users. Users can not re...
over 7 years ago in Domino / General 1 Under Consideration

All documents is therefore also a view. It would certainly be clearer if Sent were also called "All sent documents."

All documents is therefore also a view. It would certainly be clearer if Sent were also called "All sent documents." I see a big problem here if Notes remains at an old version and is not modernized. I also find it misleading for users when views ...
7 months ago in Notes 1 Future Consideration

DRAPI unify API for databases

Unify API for databases. Mail databases can not be defined in schema and PIM endpoint is less capable than Base one. For example, you search email db by DQL (or FT in view) and get sorted results.
4 months ago in Domino / General 1 Needs Clarification

SMTPUTF8 support is required to keep receiving messages

Domino should support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533) As more and more messages contains UTF8 in the headers. These messages get bounced now. RFC 6532 and RFC 6531 allow the inclusi...
about 1 year ago in Domino / General 2 Needs Clarification

Spam button in HCL Notes

Customer would like a spam button in Notes client for external mails that are suspicious. So that it will be flagged and no further spam mail from that external source arrives anymore.
about 3 years ago in Notes 4 Future Consideration