Skip to Main Content
HCL Domino Ideas Portal

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.


For more information on products and upcoming events around #dominoforever, please visit: HCL Domino Page


ADD A NEW IDEA

Clear

Ideas

Add API (Lotusscript/Java, etc.) method to place text into the OS clipboard

Ability to call a method to place arbitrary text into the OS clipboard without having to select a NotesUI field value and call copy (e.g., placeTextinClipboard(string) ). I often place non-field value text into the clipboard and achieve this by wr...
over 4 years ago in Domino Designer / LotusScript 2 Under Consideration

Domino webservice consumer that should support adding an OAuth authentication token to its header

We need the ability in Domino webservice consumer that should support adding an OAuth authentication token to its header 1.Who needs this? Developer, Application Owner, required by several webservice providers like SAP, ... 2.What do they want? Ab...
over 1 year ago in Domino / General 2 Under Consideration

Highlight variables in lotusscript

If I click on the DIM of a variable, I want to see (with a background highlight) where ir's used - so highlight the sub/function and the actual line If it's not used anywhere, then it would be easy to see that
about 8 years ago in Domino Designer / LotusScript 0 Under Consideration

Add a lotusscript method to export inline image in rich text field

Attachments files and objects are able to export by using ExtractFile method in EmbeddedObject class.But there is no method to export pasted image data to disk. Currently it can implement to use DXLExporter and ConvertNotesBitmapsToGIF. But It is ...
over 5 years ago in Domino Designer / LotusScript 0 Under Consideration

Support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533)

Domino should support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533) RFC 6532 and RFC 6531 allow the inclusion of Unicode characters in a header content using UTF-8 encoding, and their transmissio...
over 5 years ago in Domino 0 Assessment

Usage report for each mail database

This will show the following details regarding user activity in a mail database Details with the report:1. User access time 2. Record messages sent 3. Deletion message 4. Created or deleted folders 5. Mail move by rule or manually 6. Action perfor...
over 1 year ago in Domino / Administration 1 Needs Clarification

Enhance LotusScript function NotesDatabase.getOption(optionName%)

GetOption was introduced to the NotesDatabase class in V6. It allows to determine, if specific Options are set or not. But by design, it only accesses options1 from the database header. Other options are stored in options2 - options4.Those option ...
about 7 years ago in Domino Designer / LotusScript 3 Assessment

Customise the Domino Installer: Check the installed version of Verse

We had installed Domino 14.5 FP1. Regarding the following security vulnerabilities in Verse:https://support.hcl-software.com/csm?id=kb_article&sysparm_article=KB0129925We installed version 3.2.6 IF1.We then decided to upgrade to Domino version...
6 months ago in Domino / General 3 Already Exists

When a idea is shipped, post the version, link to download, and link to documentation

A lot of times I may see a aha be labeled as Shipped, but then do not know what version of Notes/Verse/Domino it is shipped for and there is no place to start a proof of concept. Without any direction this shipped feature may go under the radar. ...
over 7 years ago in Domino / General 2 Under Consideration

Move the login redirect feature to the internet site document (Notes.ini setting OIDC_LOGIN_ENABLE_REDIRECT)

Domino 14.5 now supports "third-party initiated login" via a new initiate_login_uri endpoint as defined by OIDC.Core at /auth/protocol/oidc/login. In order to leverage this functionality the default redirection needs to be disabled, but that is co...
4 months ago in Domino / Security 0 Needs Review