Skip to Main Content
HCL Domino Ideas Portal

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.


For more information on products and upcoming events around #dominoforever, please visit: HCL Domino Page


ADD A NEW IDEA

Pinned ideas

PINNED Use React components to render Notes applications
As a user I need Notes to open an application and show it using modern React based components, because it will look more modern, will be reactive to screen size, be better for accessibility, give us useful additional controls and allow us to contr...

All ideas

Add API (Lotusscript/Java, etc.) method to place text into the OS clipboard

Ability to call a method to place arbitrary text into the OS clipboard without having to select a NotesUI field value and call copy (e.g., placeTextinClipboard(string) ). I often place non-field value text into the clipboard and achieve this by wr...
over 4 years ago in Domino Designer / LotusScript 2 Under Consideration

Check mail rules when renaming or deleting folder

When a user renames or deletes a folder, check if the folder was referenced in a mail rule and, if so, alert the user.
about 8 years ago in Notes 1 Future Consideration

Synchronizing the mail signature of Notes/iNotes in Verse Mobile

As of now, there is no option to use the same signature from Notes/iNotes in the Verse Mobile. Please add an option to synchronize the mail signature of Notes or iNotes in Verse mobile so the signature will be uniform across all the IBM platfor...
over 7 years ago in Verse / Mobile (Android) 4 Under Consideration

Highlight variables in lotusscript

If I click on the DIM of a variable, I want to see (with a background highlight) where ir's used - so highlight the sub/function and the actual line If it's not used anywhere, then it would be easy to see that
about 8 years ago in Domino Designer / LotusScript 0 Under Consideration

Quota warning message when the user executes "Apply Update".

If the mail database size has exceeded the quota, and the user clicks on "Apply Update" from an updated calendar meeting. Then the user should receive a warning or prompt that the meeting will not be updated due to exceeding his database size quota.
7 months ago in Verse / Verse on Premises 0 Future Consideration

Maximum Attachment Size (KB) Field – Server Configuration Settings should work for all attachment

The 'Maximum Attachment Size (KB)' field in the Server Configuration Settings (iNotes® or HCL Verse tab in Domino 14.5) should support the total size of multiple attachments, instead of only limiting the size of individual attachments.
about 1 year ago in Verse / Verse on Premises 0 Future Consideration

Domino webservice consumer that should support adding an OAuth authentication token to its header

We need the ability in Domino webservice consumer that should support adding an OAuth authentication token to its header 1.Who needs this? Developer, Application Owner, required by several webservice providers like SAP, ... 2.What do they want? Ab...
over 1 year ago in Domino / General 2 Under Consideration

Add a lotusscript method to export inline image in rich text field

Attachments files and objects are able to export by using ExtractFile method in EmbeddedObject class.But there is no method to export pasted image data to disk. Currently it can implement to use DXLExporter and ConvertNotesBitmapsToGIF. But It is ...
over 5 years ago in Domino Designer / LotusScript 0 Under Consideration

Support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533)

Domino should support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533) RFC 6532 and RFC 6531 allow the inclusion of Unicode characters in a header content using UTF-8 encoding, and their transmissio...
over 5 years ago in Domino 0 Assessment

How can a simple user disable Group By Date in all folders?

How can a simple user disable the option "Group By Date" in all his folders? End users need to do that for each folder (too complicated and too long) or add parameters in notes.ini. (For now, this action can't be done by a simple user.) The end us...
over 3 years ago in Notes 0 Future Consideration