Skip to Main Content
HCL Domino Ideas Portal

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.


For more information on products and upcoming events around #dominoforever, please visit: HCL Domino Page


ADD A NEW IDEA

Pinned ideas

PINNED Use React components to render Notes applications
As a user I need Notes to open an application and show it using modern React based components, because it will look more modern, will be reactive to screen size, be better for accessibility, give us useful additional controls and allow us to contr...

All ideas

Make EnableJavaAgentCache=2 the default setting

This technote indicates you can set EnableJavaAgentCache=2 on a Domino server to prevent out of memory errors when Java agents use attached JAR files: https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0089161 It would be nice f...
almost 3 years ago in Domino 1 Needs Review

SMTPUTF8 support is required to keep receiving messages

Domino should support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533) As more and more messages contains UTF8 in the headers. These messages get bounced now. RFC 6532 and RFC 6531 allow the inclusi...
about 1 year ago in Domino / General 2 Needs Clarification

Configuration Document for automatically removing finished AdminP Requests

In some environments the Domino Admins are extremely lazy and don´t remove finished AdminP requests from the ADMIN4.NSF Wouldn´t it be helpful to have the option to configure that finished requests would automatically be removed from the ADMIN4.NS...
over 6 years ago in Domino / Administration 2 Under Consideration

Add support for opening a specific attachment in Formula

There is @Command( [AttachmentLaunch] ) Would it be possible to allow @Command( [AttachmentLaunch]; "AttachmentName" ) so a specific attachment can be opened with only one click?
over 3 years ago in Domino Designer / @Formulas 0 Assessment

Size of email - Search by

Idea 1: Customer is asking a way to search email by size in Verse on Premise Idea 2: Customer is asking a way to see size of each email Please release at a better speed, features on Verse on Premise.
almost 5 years ago in Verse / Verse on Premises 2 Future Consideration

Spell check for Bulgarian language

Hi there, we have migrate a furher company in our company group. We need a spell check for bulgarian language in our hcl notes client > "ASAP" ;-) Many thanks
almost 3 years ago in Notes 0 Needs Review

Add HTTP session Activity information in "Usage" section of log.nsf

As of now only the Notes session activity is being recorded in "Usage" views of log.nsf and it is very helpful in understanding the users accessing the databases and number of documents read/write in a session and the number of transactions perfor...
over 3 years ago in Domino / Reporting & Analytics 0 Under Consideration

Improve the behavior when searching contacts in Sametime Web

The customer have observed 2 behaviors when doing a contact search in embedded client vs. web client.In embedded client - entering just two characters is enough for the contact to be found, regardless of where those characters appear — at the begi...
about 1 year ago in Sametime / Chat 0 Under Consideration

Type Ahead: Most used contacts will show first

When typing an email address, any way can be cached frequently communicated email addresses whatever is send and receive on HCL Notes. So that It will lookup lookup the Most used contacts and will show first instead of Recent contacts.
about 2 years ago in Notes 1 Needs Review

"Delay delivery until" option in Mail-in Database

Email delivery can be delayed when creating an email via the Notes client. Create the email and go to "Delivery Options" and select the "Delay Delivery Until" option.Enable the delay option for Mail-In Databases
about 3 years ago in Domino / General 4 Needs Clarification