Skip to Main Content
HCL Domino Ideas Portal

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.


For more information on products and upcoming events around #dominoforever, please visit: HCL Domino Page


ADD A NEW IDEA

Clear

Ideas

Valid Semantic HTML5

The context of these suggestions is Notes Rich-Text in document, forms and pages. XPages are not considered in this text. We need to be able to produce valid HTML5 with Domino Forms, Views, Pages and so on. Please make valid HTML5 a success criter...
about 5 years ago in Domino / Integration 5 Under Consideration

Allow 2FA to use Email Only

We host systems that are used by customers who change companies all the time. Sometimes when they leave companies, we are not notified. Since people now take their BYOD phones with them, any MFA/2FA using SMS or Authenticator Apps can be used outs...
over 1 year ago in Domino / Security 5 No Plans to Implement

Server-Rules for E-Mail-Header

Our provider uses anti-spam software that writes the SPAM probability in the email header. Example: X-Spam-Level: ***** There should be a central way to evaluate the email header in Domino, for example to add a keyword to the subject line of affec...
over 2 years ago in Domino / Security 2 Under Consideration

Domino webservice consumer that should support adding an OAuth authentication token to its header

We need the ability in Domino webservice consumer that should support adding an OAuth authentication token to its header 1.Who needs this? Developer, Application Owner, required by several webservice providers like SAP, ... 2.What do they want? Ab...
over 1 year ago in Domino / General 2 Under Consideration

Support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533)

Domino should support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533) RFC 6532 and RFC 6531 allow the inclusion of Unicode characters in a header content using UTF-8 encoding, and their transmissio...
over 5 years ago in Domino 0 Assessment

DominoIQ RAG should be able to integrate with other AI services

No description provided
4 months ago in Domino / DominoIQ 5 Needs Clarification

DominoIQ interface with Designer

I would like DominoIQ to scan an existing/legacy Notes NSF design and be able to summarize the overall workflow and critical/high traffic design elements and features. An alternative spin - I would like to have DominoIQ scan the design and make re...
10 months ago in Domino Designer / Documentation 0 Needs Review

Enable "document body compression" in the mail template by default

On top of the space savings by DAOS, the advanced database property "Compress document data" can reduce the document and therefore database size significantly (up to 60%) by compressing non-summary item data in all documents in a selected database...
about 1 month ago in Domino / Administration 0 Needs Review

When a idea is shipped, post the version, link to download, and link to documentation

A lot of times I may see a aha be labeled as Shipped, but then do not know what version of Notes/Verse/Domino it is shipped for and there is no place to start a proof of concept. Without any direction this shipped feature may go under the radar. ...
over 7 years ago in Domino / General 2 Under Consideration

Better NSD crash diagnostic logs collection

We frequently encountered this situation where Domino crashed due to abnormal termination and IBM Support's reply is always the NSD log is insufficient to provide details on the crash and we need to implement NSD -monitor to troubleshoot further. ...
about 8 years ago in Domino / Administration 5 Under Consideration