Skip to Main Content
HCL Domino Ideas Portal

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.


For more information on products and upcoming events around #dominoforever, please visit: HCL Domino Page


ADD A NEW IDEA

Clear

Pinned ideas

PINNED Use React components to render Notes applications
As a user I need Notes to open an application and show it using modern React based components, because it will look more modern, will be reactive to screen size, be better for accessibility, give us useful additional controls and allow us to contr...

Ideas

Type Ahead: Most used contacts will show first

When typing an email address, any way can be cached frequently communicated email addresses whatever is send and receive on HCL Notes. So that It will lookup lookup the Most used contacts and will show first instead of Recent contacts.
about 2 years ago in Notes 1 Needs Review

SMTPUTF8 support is required to keep receiving messages

Domino should support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533) As more and more messages contains UTF8 in the headers. These messages get bounced now. RFC 6532 and RFC 6531 allow the inclusi...
about 1 year ago in Domino / General 2 Needs Clarification

Drag & Drop attachment from email direct to any web application.

Notes client, dragging attachment direct from email to any web application (example cloud) or directly to Skype doesn't work. Attachment uploads to web application as 0 bytes!
over 6 years ago in Notes 2 Future Consideration

Keep Alive TCP 1352 protocol

This is a common and old problem about Notes NRPC in a network. The protocol TCP don't have a keep alive inside... Many experience here: https://www.dominopoint.it/dominopoint/dominopoint_blog.nsf/dx/keepalive-notes-client-problemi-sedi-remote-tim...
about 2 years ago in Notes 1 Needs Review

Support XLSX Files as Import Source

Notes used to support importing data directly from a 123 spreadsheet. It would be great to support importing directly from an XLSX file.
about 4 years ago in Notes 0 Future Consideration

Add parameters to @Command( [FilePageSetup] )

Currently @Command( [FilePageSetup] ) displays a dialog on which user has to interactively specify parameters such as page margins. It should be possible to set all these parameters automatically by @Command and/or through LotusScript method.
about 4 years ago in Domino Designer / @Formulas 0 Under Consideration

Need the way to customize multiple views at a time

End user can customize their view from the menu [View]-[Customize This View]. That way, end user who do not have designer access can customize their mail view as they like.However, it is sometimes hard work for end user to change all of folders/vi...
about 8 years ago in Notes 0 Future Consideration

More Notes Client Application focus

This isn't anything specific but more general rambling on product direction. I've seen a lot more focus on the web side of Notes/Domino while Notes client development is being left in the dust. The whole reason why Notes/Domino is popular in the f...
over 7 years ago in Domino Designer 5 Under Consideration

Request to all events reported in log.nsf

There are some events in the console log file that are not reported to log.nsf. Examples of such events are: - LkMgr BEGIN Long Held Lock Dump ------------------ - DbMarkCorrupt(Duplicate DbName found) Administrator want to receive alert when the ...
over 2 years ago in Domino / General 2 Under Consideration

More bootstrap responsive custom controls

Make available other Bootstrap responsive custom controls
about 8 years ago in Domino Designer 1 Under Consideration