Skip to Main Content
HCL Domino Ideas Portal

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.


For more information on products and upcoming events around #dominoforever, please visit: HCL Domino Page


ADD A NEW IDEA

Clear

General

Domino CAPI AgentQueryStdoutBuffer isn't populated by setting up and using the java agent method getAgentOutput()

The CAPI AgentQueryStdoutBuffer isn't populated by setting up and using the java agent method getAgentOutput() , the buffer is empty. If possible, would like to have this fixed for r12 and r14. Here is a java agent example (pretty much taken from ...
over 2 years ago in Domino / General 1 Assessment

DRAPI unify API for databases

Unify API for databases. Mail databases can not be defined in schema and PIM endpoint is less capable than Base one. For example, you search email db by DQL (or FT in view) and get sorted results.
3 months ago in Domino / General 1 Needs Clarification

Move all documentation, examples etc to Git

It would be really great if HCL could move all documentation related to especially LotusScript, @Formula, NodeJS and Java (both standard Java in agents, servlets, OSGi and Proton Java gRPC API) etc to Git so that everyone could participate in exte...
about 5 years ago in Domino / General 0 Assessment

Excluding forms directly from full-text indexes is not supported.

In Domino 12, there is an option to exclude fields from full-text indexes. Please refer to the article below for the steps and more details. Title: Specifying fields to exclude from full-text indexes https://help.hcl-software.com/dom_designer/12.0...
almost 2 years ago in Domino / General 1 Needs Review

SMTPUTF8 support is required to keep receiving messages

Domino should support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533) As more and more messages contains UTF8 in the headers. These messages get bounced now. RFC 6532 and RFC 6531 allow the inclusi...
about 1 year ago in Domino / General 2 Needs Clarification

Use IF1 or 2... instead of SHF123 as product version. SHF is IBM internal management number, is not understadable what it is all about.

SHF is used for everywhere in Interim Fix (IF) like in product (Help - About) and downloaded program like 852FP4SHF470_W32_standard.exe. IF number shall be added. SHF is IBM internal management number and nothing to do with users. Users can not re...
over 7 years ago in Domino / General 1 Under Consideration

"Delay delivery until" option in Mail-in Database

Email delivery can be delayed when creating an email via the Notes client. Create the email and go to "Delivery Options" and select the "Delay Delivery Until" option.Enable the delay option for Mail-In Databases
about 3 years ago in Domino / General 4 Needs Clarification

Request to all events reported in log.nsf

There are some events in the console log file that are not reported to log.nsf. Examples of such events are: - LkMgr BEGIN Long Held Lock Dump ------------------ - DbMarkCorrupt(Duplicate DbName found) Administrator want to receive alert when the ...
over 2 years ago in Domino / General 2 Under Consideration

Let domconfig.nsf allow multiple login forms based on the URL

Would like the ability to to map a Login form to a specific URL. This way we can have different login pages with different details, logo's etc For example, If the user is trying to hit database A, the login form presented is specific to Database A...
about 1 year ago in Domino / General 1 Under Consideration

Speed up saving Internet Site documents

Saving Internet Site documents is pretty slow. The reason for that is in the QuerySave of the $internetSite sub form, searching for a Certifier document corresponding to the Organization item. The code loops through every view entry in the ($Certi...
over 3 years ago in Domino / General 0 Assessment