Skip to Main Content
HCL Domino Ideas Portal

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.


For more information on products and upcoming events around #dominoforever, please visit: HCL Domino Page


ADD A NEW IDEA

Clear

Ideas

Workflow Diagram XPages Control

Workflow diagram control support xml data to display in workflow diagram
over 7 years ago in Domino Designer / XPages 0 Under Consideration

Modify NotesThread.NnotesInitThread to report error codes in hexadecimal

Currently, if there is an exception in process/thread initialization, the status is reported as a decimal number: java.lang.Exception: Notes initialization failure - err 433 at lotus.domino.NotesThread.NnotesInitThread(Native Method) at lotus.do...
over 5 years ago in Domino Designer / Java 0 Assessment

Provide nice looking basic templates with nice colors, icons, action buttons, shades.

we need 3-4 templates, different colors with great color themes, nice looking icons, state of art backgrounds. To create a nice app only code need to be added. Now Domino apps are very functional but not always look good.
almost 8 years ago in Domino Designer 2 Assessment

Explicit indicator when LS-Debugger is enabled

often I forget to deactivate the LS-Debugger before opening e.g. the mailfile - this isn't funny - i need an explicit indicator in the Notes Client that the Debugger is still active... Dirk Kirchhoff
about 8 years ago in Domino Designer 4 Under Consideration

Extend GetItemValue() function

In a large part of my LS code, I always have to use HasItem() to check whether the item really exists. It would be nice if an optional parameter could be passed that returns a default value if the item doesn't exist.
over 4 years ago in Domino Designer / LotusScript 2 Under Consideration

Excluding forms directly from full-text indexes is not supported.

In Domino 12, there is an option to exclude fields from full-text indexes. Please refer to the article below for the steps and more details. Title: Specifying fields to exclude from full-text indexes https://help.hcl-software.com/dom_designer/12.0...
almost 2 years ago in Domino / General 1 Needs Review

Allow updating rich-text items to match in the back-end without using refresh

Currently, using NotesUiDocument.Refresh with the parameter True is the only possibility to access values entered in a rich text item directly in the back end document without saving the document. The current implementation gets problematic when a...
almost 5 years ago in Domino Designer / LotusScript 1 Under Consideration

Allow "Open in New Window" in Domino Designer

Just like in Notes Client, I would like to have the ability to open a design element in a new window. It would be great to compare code between 2 forms or views (on two screens) or have a form open to see the names of the fields while building the...
about 3 years ago in Domino Designer 0 Under Consideration

Display the multiple entries in XPage view (browser) based on a search string.

Multiple Notes documents can have a common text/string present in them in a notes database. If you use this text as a search string in the search bar, then a matching output appears. All the documents having this text will be highlighted in Notes...
about 3 years ago in Domino Designer / XPages 0 Under Consideration

SMTPUTF8 support is required to keep receiving messages

Domino should support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533) As more and more messages contains UTF8 in the headers. These messages get bounced now. RFC 6532 and RFC 6531 allow the inclusi...
about 1 year ago in Domino / General 2 Needs Clarification