Skip to Main Content
HCL Domino Ideas Portal

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.


For more information on products and upcoming events around #dominoforever, please visit: HCL Domino Page


ADD A NEW IDEA

Clear

Ideas

Integrate Project Keep into the next release of Domino

From the list of API (https://frascati.projectkeep.io/openapi/), Project Keep seemed to be a good alternative for those of us who cannot deploy App Dev Pack. Also Project Keep seemed to utilise the Domino instead of just using NSF as a data storag...
about 6 years ago in Domino / Integration 0 Under Consideration

In categorized views, build the column-sums with obeying the users permissions

Today, the only way to get permission-sensitive column-sums in categorized views is private on first use, which leads to hundreds of personal views in our databases that all want to be maintained. Once they get too many they can even cause stabili...
over 8 years ago in Domino 0 Under Consideration

Mail Template & Router : Allow recall scheduled message for all recipients(include internet mail recipients) when recall requested(before delivery).

V10 support scheduled message, but recall for the scheduled message works after the message is delivered to recipients. Please recall the scheduled message for all recipients in mail.box as soon as possible(before delivery) and allow recall schedu...
over 7 years ago in Domino 1 Assessment

Domino Internet CA should support current standards

The Domino Internet CA currently does not have extended key usage nor Subject Key Identifier/Authorized Key Identifier (not yet enforced) added to certificates. Those attributes are needed today to be compatible with other environments like Apple ...
about 1 year ago in Domino / Security 0 Needs Review

Force password change after next login checkbox

Please add a policy that forces the password to be changed at the next login. The policy should be immediately broadcast to all connected HCL Notes clients so that in case of a security problem, everyone is forced to use a new password. The settin...
over 3 years ago in Domino / Security 3 Under Consideration

SMTPUTF8 support is required to keep receiving messages

Domino should support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533) As more and more messages contains UTF8 in the headers. These messages get bounced now. RFC 6532 and RFC 6531 allow the inclusi...
about 1 year ago in Domino / General 2 Needs Clarification

Delete messages in all archive replicas when you click the "Restore and delete" button.

As a user, I want the "Restore and Delete" button in the archive to delete the message in all archive replicas. Currently, when using this button, the message is restored if the archive has replicas. This results in duplicate messages in both the ...
8 months ago in Domino / General 0 Needs Review

Additional Option required to access database on other Domino Server by Agent Signer ID.

Agent Manager task is currently responsible for execution of all scheduled agents that run on Domino Server. The agent manager is one of the Domino server processes. When any scheduled agent needs to access some other database present on another D...
over 4 years ago in Domino / Security 1 Already Exists

Improve the integration of Jenkins and Git with Domino to automate the process of replacing templates in applications

In times of pandemic with COVID-19, many companies are adopting the home office work model, so the need to improve and facilitate Jenkins and Git integration with Domino as much as possible to automate the process of updating template.
over 6 years ago in Domino / Administration 0 Under Consideration

Restyle dialog itself needs restyling

in step 2 of the restyling process ("confirm mapping") we need to choose a set of elements (forms or pages) then the name of that element. The comboboxes for the elements' names are way too narrow for long names; it can become a trial-and-error jo...
about 3 years ago in Domino Designer / ReStyle 0 Under Consideration