Skip to Main Content
HCL Domino Ideas Portal

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.


For more information on products and upcoming events around #dominoforever, please visit: HCL Domino Page


ADD A NEW IDEA

Clear

Ideas

DRAPI unify API for databases

Unify API for databases. Mail databases can not be defined in schema and PIM endpoint is less capable than Base one. For example, you search email db by DQL (or FT in view) and get sorted results.
4 months ago in Domino / General 1 Needs Clarification

SMTPUTF8 support is required to keep receiving messages

Domino should support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533) As more and more messages contains UTF8 in the headers. These messages get bounced now. RFC 6532 and RFC 6531 allow the inclusi...
about 1 year ago in Domino / General 2 Needs Clarification

Dedicated Option/setting to redirect to a specific page solely for re-logins after session expiry.

Customer requirement, a dedicated option or setting that enables redirection to a specific page exclusively for re-logins following session expiration (session timeout). As an alternative way/ method can be, the custom login form using $$LoginUser...
10 months ago in Domino / Administration 0 Needs Review

Make EnableJavaAgentCache=2 the default setting

This technote indicates you can set EnableJavaAgentCache=2 on a Domino server to prevent out of memory errors when Java agents use attached JAR files: https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0089161 It would be nice f...
almost 3 years ago in Domino 1 Needs Review

Configuration Document for automatically removing finished AdminP Requests

In some environments the Domino Admins are extremely lazy and don´t remove finished AdminP requests from the ADMIN4.NSF Wouldn´t it be helpful to have the option to configure that finished requests would automatically be removed from the ADMIN4.NS...
over 6 years ago in Domino / Administration 2 Under Consideration

Add HTTP session Activity information in "Usage" section of log.nsf

As of now only the Notes session activity is being recorded in "Usage" views of log.nsf and it is very helpful in understanding the users accessing the databases and number of documents read/write in a session and the number of transactions perfor...
over 3 years ago in Domino / Reporting & Analytics 0 Under Consideration

"Delay delivery until" option in Mail-in Database

Email delivery can be delayed when creating an email via the Notes client. Create the email and go to "Delivery Options" and select the "Delay Delivery Until" option.Enable the delay option for Mail-In Databases
about 3 years ago in Domino / General 4 Needs Clarification

Option to avoid horizontal scrolling

When scrolling on a document on a mobile device, the document can also be scrolled sideways, even if the design is made for small screens Provide an option to prevent sideways scrolling
over 6 years ago in Nomad / Nomad (Android) / Nomad (iOS) 0 Needs Review

Provide a way to manage mail-in database features - policies don't work

HCL support asked me to request this. I had opened a support ticket because I could not find a way to turn on the Enable Alternate From Feature and Automatically use the internet address of Mail-in database as sender for hundreds of mail-in databa...
over 2 years ago in Domino / Administration 0 Under Consideration

Configure the Domino HTTP server to ignore "Authorization: Bearer" headers on Domino 12.0.2

This has always worked well in Domino 10, 11 and 12.0 but now HCL has implemented an option on the internet site to use a bearer token. The problem with this option is that you then need to configure an OIDC provider which is not well documentated...
over 3 years ago in Domino / Security 3 Under Consideration