Skip to Main Content
HCL Domino Ideas Portal

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.


For more information on products and upcoming events around #dominoforever, please visit: HCL Domino Page


ADD A NEW IDEA

Clear

Ideas

Designer Task performance improvements

We are facing situation when design task on 1600 custom dbs ran for more than 8 hours while doing full design upgrade. After checking different settings, it turned out that in runs 10x faster when the database is not transactionally logged. HCL Su...
about 2 years ago in Domino / Administration 4 Needs Clarification

typeahead for ACL entry

It would be great to have typeahead. Now to not mistype, users have to click USER icon, search pick. If user is unique, just type surname and let system fill user name
over 7 years ago in Domino / Security 0 Under Consideration

Error handling: try.. catch java-style error handling in Lotusscript

Even javascript has this! java/javascript is like this: try { some lines of code... some code that erros } catch(error) { deal with error } With new Try Catch End Try block, Lotusscript could be .. Try Do this Do that Do another Catch <...
about 8 years ago in Domino Designer / LotusScript 2 Under Consideration

LotusScript Date time Object: New NotesDateTime ("2017-3-7") - is this in March or July?

What date is  to be expected from "New NotesDateTime ("2017-3-7")" ? According to ISO 8601 (valid in the U.S. too) this  would mean 2017  - March - 7th. However, in my German Notes (both, 901 and 10), the result is different (A...
about 7 years ago in Domino Designer / LotusScript 0 Under Consideration

Add a "Home server" field in the Person document

Currently, there is one field, "Mail server", containing the server handling incoming emails for a user. If I'm not mistaken, this field is also used to create the initial Online location for the user (field "Home/mail server"). If I change the fi...
over 7 years ago in Domino / Administration 0 Under Consideration

Administrator needs option to record output of "load compact" or "replicate" command output in text file.

When we issue a command "load compact -B abc.nsf" command on domino server console output is recorded in log.nsf database and in the Domino server console.log file. Currently we can create program document for server commands: sh server, sh task a...
over 5 years ago in Domino / Administration 1 Needs Clarification

"From" field in the address details of received mail should display the name of the email address who forwarded the mail to the recipient

"From" field in the address details of received mail should display the name of the email address who forwarded the mail to the recipient. Mails which are forwarded by a rule (or by the use of a forwarding address) show the name of the first origi...
over 6 years ago in Domino / Administration 1 Under Consideration

Conflict handling - add an option to merge a field (especially document history fields)

Many developers add a "history" field in their applications to document when/who updated a document and what happened. This prevents the "Conflict Handling" form property "Merge Conflicts" option from working as there could always be a difference ...
over 7 years ago in Domino Designer / LotusScript 4 Under Consideration

Time-based One Time Password (TOTP) two-factor authentication for Domino server

Currently, Multi Factor Authentification (MFA) is only possible via external service providers. However, components such as SMS gateways (e.g. SMSEagle) are already available in many server architectures. For this reason, support for the internall...
about 2 years ago in Domino / Security 4 Already Exists

RNR Database should be able to replicate when $CSTrack exceeds 65,000 bytes

At RNR database when $CSTrack exceeds 65000 bytes, database does not replicate and gives error message "Memory allocation request exceeded 65,000 bytes". SPR#SSARBUMJFJ already raised for this which is treated as Feature Request.
over 4 years ago in Domino / Administration 0 Under Consideration