Skip to Main Content
HCL Domino Ideas Portal

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.


For more information on products and upcoming events around #dominoforever, please visit: HCL Domino Page


ADD A NEW IDEA

Clear

Ideas

Allow servers to run agents on foreign servers

In Domino it is not possible to have ServerA start an agent on ServerB. This will generate "Error 4184 Cannot access foreign servers when running on a server". The workaround is to call the agent through an http-call which present a lot of other o...
over 3 years ago in Domino / Administration 6 Needs Clarification

Dedicated Option/setting to redirect to a specific page solely for re-logins after session expiry.

Customer requirement, a dedicated option or setting that enables redirection to a specific page exclusively for re-logins following session expiration (session timeout). As an alternative way/ method can be, the custom login form using $$LoginUser...
10 months ago in Domino / Administration 0 Needs Review

Allow mail soft deletions (trash folder) to replicate to other servers

If you create a mail replica on another server the soft deletions (trash folder) do not replicate. It makes sense that all documents should replicate regardless or not if they are in the Trash folder.
over 6 years ago in Domino / Administration 2 Under Consideration

Allow Maximum size limit for console log beyond 4gb or unlimited.

Domino server console.log has a maximum size cap of 4GB. When the ini "Console_Log_Enabled=1" is set on the server, console log is getting overwritten when it reaches 4GB size. There should be a way to have the console.log file unlimited on the s...
about 4 years ago in Domino / Administration 1 Needs Clarification

SMTPUTF8 support is required to keep receiving messages

Domino should support for Email Address Internationalization OR Internationalized Email specs SMTPUTF8 (RFC6530 - 6533) As more and more messages contains UTF8 in the headers. These messages get bounced now. RFC 6532 and RFC 6531 allow the inclusi...
about 1 year ago in Domino / General 2 Needs Clarification

Add support for http QUIC protocol on Domino

The HTTP QUIC protocol (enabling HTTP/3) is an enhancement on the transport protocol layer between http clients and servers, and offers much lower latency. As such, QUIC provides a more seamless consumption of web services, particularly on high-sp...
over 5 years ago in Domino 0 Under Consideration

Fix the LS2J bug "Error loading USE or USELSX module.." It has been around forever!

When using LS2J often you will get the error "Error loading USE or USELSX module.." at UseLSX "*javacon" in LotusScript in the Designer. There is no error! ... but the Designer reports an error and you can not compile. It is very annoying because ...
about 8 years ago in Domino Designer / LotusScript 5 Under Consideration

Use IF1 or 2... instead of SHF123 as product version. SHF is IBM internal management number, is not understadable what it is all about.

SHF is used for everywhere in Interim Fix (IF) like in product (Help - About) and downloaded program like 852FP4SHF470_W32_standard.exe. IF number shall be added. SHF is IBM internal management number and nothing to do with users. Users can not re...
over 7 years ago in Domino / General 1 Under Consideration

Easier conversions from Rich Text to other Format

Easier conversions from Rich Text-Fields to HTML, RTF, PDF etc and back without Declare API function.
over 7 years ago in Domino Designer / LotusScript 0 Under Consideration

Add a possibility to include LotusScript into xPages

Benefit: use existing code in (existing and new) applications independently of the usage of xPages or native design elements. The goal is to write code once and use it at different places. Please note (written after first comments) that this ide...
about 8 years ago in Domino Designer / LotusScript / XPages 4 Under Consideration